Windows audio playing when transmitting ? #Software


Andrew OBrien
 

Hmm, I think I am getting senile our something in Windows has changed.  Usually we all set our digital mode software to the USB Codec of modern receivers and are thus able to operate digital modes while listening to other audio on our computers.  This avoid Windows sound going out over the air .  However since I switched from Flex radios (where I used VAC mostly) to an Icom 7610 I have to set my Windows defaults sound to USB Codec in order for audio tones to flow to the transmitting radio. When I do this, I therefore cannot play other sounds on the computer... they get transmitted. I always thought that I could select the PC speakers as my default Windows sound and as log as the digital mode software was set to USB Codec I could transmit without worrying about Windows sounds.  What am I doing wrong.  I tried it on 2 PCs.
Andy K3UK


Graham
 

Hi Andy,

Im running the  IC7100  , that shows up as usb speakers  and  microphone in 
[ the  microphone , is a  non compatibility in windows above  win-xp , should 
be  low  gain line in]

Looking at my  win-7  control  panel  , audio 

There  is a  option, to  set Default  Device  , with  second  option  
Default Communication  Device 

Ive not changed the  settings , but,  I suspect  , that  may be 
linked to  your issue ?

73-Graham 


Andrew OBrien
 

Thanks for your reply Graham . I tried changing those settings yesterday , still same outcome . You may be right , I’ll check there again . Your 7100 does not use USB codec ? 

Andy 

On Mar 5, 2019, at 7:19 AM, Graham <g0nbd@...> wrote:

Hi Andy,

Im running the  IC7100  , that shows up as usb speakers  and  microphone in 
[ the  microphone , is a  non compatibility in windows above  win-xp , should 
be  low  gain line in]

Looking at my  win-7  control  panel  , audio 

There  is a  option, to  set Default  Device  , with  second  option  
Default Communication  Device 

Ive not changed the  settings , but,  I suspect  , that  may be 
linked to  your issue ?

73-Graham 


Graham
 

Andy,

Yes,  the  ic7100  is  running  with the   USB  driver , providing    ,  CAT  control  and   Data   tx/rx  feed 

Opera is showing ,  

device input   microphone  [ 5 usb  audio  codec
device  out  put   speakers  [5-usb audio codec 

cat  comm  6 19200  baud 

ports ect  may change , depending on  availability 
at the  time  of  start up  etc 

Iv an idea, that the  ability to  select comm's  may be  causing  problems 

also , ive noticed there  is  some  interaction, with   the set not being  powered
on, at boot up  and  the  apps being  open ...not 100% sure , but , ive noticed 
sometime need  to re  boot  or  close and re  open for the  device  lists  to be  populated 

GL !  73-Graham 



Andrew OBrien
 

My sound settings are attached, software is set for USB Codec  as expected.  Odd, just checked with a local ham who has same rig and also running Windows 10.  Using same settings his works as we would want, mine will not.
Andy K3UK

On Tue, Mar 5, 2019 at 9:09 AM Graham <g0nbd@...> wrote:
Andy,

Yes,  the  ic7100  is  running  with the   USB  driver , providing    ,  CAT  control  and   Data   tx/rx  feed 

Opera is showing ,  

device input   microphone  [ 5 usb  audio  codec
device  out  put   speakers  [5-usb audio codec 

cat  comm  6 19200  baud 

ports ect  may change , depending on  availability 
at the  time  of  start up  etc 

Iv an idea, that the  ability to  select comm's  may be  causing  problems 

also , ive noticed there  is  some  interaction, with   the set not being  powered
on, at boot up  and  the  apps being  open ...not 100% sure , but , ive noticed 
sometime need  to re  boot  or  close and re  open for the  device  lists  to be  populated 

GL !  73-Graham 



Ev Tupis <w2ev@...>
 

Hi Andy.  You may have heard "If it does not fit, you must acquit."  However, a lesser know mantra is, "If it does not compute, you must reboot."

Although it will reset *all* of your customizations, in the end you may wish to restore the rig to factory defaults and reconfigure.

Kindly,
Ev, W2EV


On Tuesday, March 5, 2019, 9:56:51 AM EST, Andrew OBrien <k3ukandy@...> wrote:


My sound settings are attached, software is set for USB Codec  as expected.  Odd, just checked with a local ham who has same rig and also running Windows 10.  Using same settings his works as we would want, mine will not.
Andy K3UK

On Tue, Mar 5, 2019 at 9:09 AM Graham <g0nbd@...> wrote:
Andy,

Yes,  the  ic7100  is  running  with the   USB  driver , providing    ,  CAT  control  and   Data   tx/rx  feed 

Opera is showing ,  

device input   microphone  [ 5 usb  audio  codec
device  out  put   speakers  [5-usb audio codec 

cat  comm  6 19200  baud 

ports ect  may change , depending on  availability 
at the  time  of  start up  etc 

Iv an idea, that the  ability to  select comm's  may be  causing  problems 

also , ive noticed there  is  some  interaction, with   the set not being  powered
on, at boot up  and  the  apps being  open ...not 100% sure , but , ive noticed 
sometime need  to re  boot  or  close and re  open for the  device  lists  to be  populated 

GL !  73-Graham 



Graham
 

Andy  

Only one of my  devices  has the  'green  tick'    
your  showing   two ... ?  
can you  un-tick  one  of them  ?

G,


Oliver K6OLI
 

Andy,

you do not want to set your USB Audio CODEC as Default Communications Device nor as Default Device.  Your computer internal soundcard should be set to Default Communications Device nor as Default Device (see image below). 

Yes, that means that you have to check the USB Audio CODEC is selected in your software (Fldigi, Soundmodem, for example)  before transmitting, just to be sure. But it avoids keying your rig everytime you want to play music or watch a Youtube video, because those will be played through your Default Audio Device, i.e. your computer internal soundcard.

Hope that helps.

73,
Oliver K6OLI


Andrew OBrien
 

This is what I have, still no change.  I see there are two green buttons, I am unable to turn off the green button in the Default Communication Device area. 


Graham
 

Andy,

May need to  try and define  some of the  other  devices , then  back to  the  wanted config ,
perhaps system restore to before the  icom driver was installed 
check the  mixer  is not picking the  two  devices  up ?

73 -G


Oliver K6OLI
 

Andy,

Just right-click on on your Speakers (High Definition Audio Device)
Now select Set as Default Communications Device 
The green check mark will now only be on Speakers (High Definition Audio Device) and the Speakers (2-USB Audio CODEC) will no longer have a green checkmark.

Hope this helps.

73,
Oliver K6OLI


Andrew OBrien
 

Oliver, when I do that... the audio from digital mode software plays through the PC speakers NOT the radio. This is despite having the digital mode software set to use the USB Audio Codec.

Andy K3UK

On Tue, Mar 5, 2019 at 7:59 PM Oliver D <km6dmf@...> wrote:
Andy,

Just right-click on on your Speakers (High Definition Audio Device)
Now select Set as Default Communications Device 
The green check mark will now only be on Speakers (High Definition Audio Device) and the Speakers (2-USB Audio CODEC) will no longer have a green checkmark.

Hope this helps.

73,
Oliver K6OLI


Oliver K6OLI
 

Hi Andy,

What digital mode software are you using?  I have an IC-7100 which I use for digital, especially Fldigi, Soundmodem and VARA, and my settings are exactly the way I described.  Sometimes, especially after Windows Updates or when plugging into a different USB port, I need to double-check that the proper USB Audio CODEC is selected in the audio setup of the software.

When using a different USB port you can also run into the situation where it says 2-USB Audio CODEC or 3-USB Audio CODEC.  I also use USB hubs, so that can change the USB Audio CODEC enumeration.  Therefore, I have simply gotten in the habit to do a quick pre-flight check in the software audio setup before getting on the air.

Please check you audio setup in your digital software again, it may have gotten changed for a variety of reasons. In Windows nothing ever seems to be set-it-and-forget-it :-)

73,
Oliver K6OLI